Installing nightly build on mac 10.6.8

Pencil2D Forums Installing Pencil2D / How to Installing nightly build on mac 10.6.8

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of b atkinson b atkinson 6 months, 1 week ago.

  • Author
    Posts
  • #29176 Score: 0
    Profile photo of b atkinson
    b atkinson
    Participant

    I can’t seem to get any of the nightly builds to open on mac osx 10.6.8. Is this operating system too old to run the newer iterations of the software or could it be something I’m doing wrong/a different problem.

    I’ve downloaded the zip file from the google drives mac page, unzipped it, but any time I attempt to start the program by clicking on the enclosed pencil application I am presented with a message to check with developer to make sure Pencil2d works with this version of Mac OSX.

    Mac beta version runs fine on late 2007 macbook core2duo running 10.6.8

    thanks

  • #29177 Score: 0
    Profile photo of Jose Moreno
    Jose Moreno
    Moderator
    113 pts

    @bress Good evening. I’m afraid I can’t provide you with much technical support for MAC computers.

    If you’d like we can open an issue on Github so one of the developers can see if there’s a way to solve this problem. It’s weird that this is happening though, since one of the strong points of these nightly builds is that they do work with MAC OSX machines from snow leopard onwards If I recall correctly, as opposed to the previous version.

    This issue may also happen because Pencil2D is not being acknowledged by the OS as a “verified” app. So perhaps the OS is blocking Pencil2D on the premise that it might be potentially unwanted software, but that’s just a guess.

    —–
    @scribblemaniac do you have some thoughts on this issue, if you find the time?

  • #29179 Score: 0
    Profile photo of b atkinson
    b atkinson
    Participant

    Thanks for the reply.

    Interesting, yes it doesn’t really give me any other options to solve it on my end,just the message to check with developer and an option to send a report to Apple.

    Unless it’s something obvious I’m not doing correctly.

  • #29181 Score: 1
    Profile photo of scribblemaniac
    scribblemaniac
    Participant
    3 pts

    Sorry for the delay, I was unable to login yesterday. Anyway, this definitely sounds like a compatibility issue not any issue with what you’re doing. Here are a few things you can do:
    – When you get the message, select the send report to Apple option, and it should come up with a dialog box that has a textbox full of diagnostic information. If you can copy the contents of that textbox here, that may be helpful. You don’t actually have to send it to Apple, you can cancel it from that dialog.
    – Do you have an Intel or a PowerPC computer? It should say in the Apple Menu > About this Mac… popup.

    Most likely your operating system is just too old for Pencil2d. The framework we used apparently dropped Snow Leopard support recently. If you are up for a challenge, you can probably compile on your computer to get it to work, it just depends on how much work you want to put into it and how good you are with computers.

    Profile photo of Jose Moreno
  • #29197 Score: 0
    Profile photo of b atkinson
    b atkinson
    Participant

    No worries. Thanks for the reply.

    I haven’t had chance to get on to my computer of late, hopefully I’ll do it in the next few days and I’ll post the diagnostic info. I think I’m on an intel if my memory serves me, but again I’ll check and post it soon.

    I don’t have to much experience, but if the instructions are clear enough I’d give it a go.

You must be logged in to reply to this topic.